АлексейРИ
26.09.2020 17:10

Составить программу, резервирующую матрицу M размерности 10х10 и заполняющую ее случайными числами. Затем распечатывает матрицу и меняет местами элементы первого и последнего столбика и снова распечатывает матрицу М. В программе предусмотрена процедура заполнения матрицы ( CreateRandomMatr), процедура модификации матрицы ModifyMatr и процедура печати элементов матрицы PrintMatr. Передача данных в процедуры выполняется по ссылке , очень сильно нужно.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Treed1
19.02.2023 16:16
Традиционное решение:
var
  n,d1,d2,d3,d4:integer;
begin
  Write('Введите четырехзначное натуральное число: ');
  Readln(n);
  d1:=n div 1000; d4:=n mod 10;
  d3:=(n mod 100) div 10;
  d2:=(n mod 1000) div 100;
  n:=1000*d1+100*d3+10*d2+d4;
  Writeln('Результат: ',n)
end.

Тестовое решение:
Введите четырехзначное натуральное число: 4567
Результат: 4657

Решение с использованием символьного представления числа:
var
  s:string;
begin
  Write('Введите четырехзначное натуральное число: ');
  Readln(s);
  Writeln('Результат: ',s[1]+s[3]+s[2]+s[4])
end.
0,0(0 оценок)
Ответ:
Zan22
09.03.2022 18:04

1) Робот проедет вперёд на 2 полных оборота со скоростью 30

2)Робот проедет назад 0,25 полный оборот со скоростью 50

3)Робот проедет вперёд на -2 оборота со скоростью 50

4) Робот поднимет руку вверх на на 9 градусов со скоростью вращения 50

1) Робот проедет вперёд на 0,25 полных оборота со скоростью 50

2) Робот проедет назад -0,2 полный оборот со скоростью 50

3) Робот проедет вперёд на 0,25 оборота со скоростью 40

4)Робот поднимет руку вверх на 90 градусов со скоростью вращения 40

5)Робот проедет вперёд на 6 полных оборота со скоростью 75

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота