У Вас есть фрагмент рулона с автобусными билетами. Написать программу, которая определяет количество счастливых билетов в этом фрагменте. Номера начала и конца фрагмента (два целых шестизначных числа) вводятся с клавиатуры. В случае, если пользователь ввел не шестизначное число выводить на экран сообщение о вводе некорректных данных. на языке си
Значитса тебе надо найти квадраты чисел до самого N ,для этого мы объявляем переменную k и присваиваем ей 1 и переменную s, которой присваиваем значение 0, после делаем цикл от 1 до N с шагом 1 и там же к s прибавляем k, а k увеличиваем на 2 ( на 1 шаге k=3, на 2 k=5 и т. д., то есть нечетные числа) ну и выводим в цикле s
#include <iostream> #include <conio.h> using namespace std; int main() { int N; cin>>N; int k=1,s=0; for(int i=1;i<=N;i++) { s=s+k; k=k+2; cout<<i<<"^2 = "<<s<<endl; } _getch(); return 0; }
Определим минимальную кодировку. Это делается так: i - это кол-во бит. Например тут i = 2, этого хватило бы для 3 спортсменов. то есть 9 бит хватило бы для 511 спортсменов. А нам надо 779. Значит увеличиваем кол-во бит Этого хватило бы для 1023 спортсменов. Нам хватает.
Значит минимальное кол-во бит для кодирования - 10 У нас а каждая запись кодируется 10 битами, значит умножив 280 на 10, мы найдём объём всех записей. 280 * 10 = 2 800 бит ответ: 2 800 бит или 350 байт.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку