лина28051
17.09.2020 11:00

решить задачу. Желаьтельно на питоне или С++, номожно и на паскале ABC.NET. НОД и НОК

Петя задумал два натуральных числа – a и b, a ≤b, и сообщил Саше числа c и d, c=НОД(a,b) d=НОК(a,b) (c∙d<2 000 000 000). Ваша программа по введенным c и d должна найти числа a и b (если это возможно – Петя мог посчитать c и d неправильно). Если a и b определяются неоднозначно, необходимо вывести все возможные пары a и b (по одной в строке).

Формат ввода
Вводятся числа c и d через пробел.

Формат вывода
Выводятся пары a и b по одной в строке или сообщение Пара не существует.

Ввод
2 60
Вывод
2 60
4 30
6 20
10 12
Ввод
1997 25962
Вывод
Пара не существует

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ари53
29.12.2021 07:50

Python 3.9

Объяснение:

c, d = map(int, input("Input c d: ").split())

a=int(c/c)

b=int(d/c)

dem=int(d/c)

if c*d<2000000000:

   if d%c==0:

       print(a*c, b*c)      

       for i in range(dem):

           b=int(d/c)

           for j in range(dem,0,-1):  

               if a<=b:

                   if a*b==dem:

                       if b%a!=0:

                           print(a*c, b*c)

                   b=b-1

               else:

                   break

           a=a+1

   else:

       print("Пара не существует")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота