aruka00000
23.01.2020 10:26

Написать программу на С++ Задание:
Использовать матрицу размерностью 7 на 7.
[Сформировать транспонированную матрицу В из А. Найти сумму и
количество отрицательных элементов в ней.]

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ruslanbaxsiev79
04.03.2020 13:43
Поиск информации – одна из самых востребованных на практике задач, которую приходится решать любому пользователю Интернета.

Существуют три основных поиска информации в Интернет:

1. Указание адреса страницы.

2. Передвижение по гиперссылкам.

3. Обращение к поисковой системе (поисковому серверу).

Указание адреса страницы

Это самый быстрый поиска, но его можно использовать только в том случае, если точно известен адрес документа или сайта, где расположен документ.

Не стоит забывать возможность поиска по открытой в окне браузера web-странице (Правка-Найти на это
0,0(0 оценок)
Ответ:
Emma510
29.12.2022 04:25
Const n=4;
var f:text;
a:array[1..n,1..n] of integer;
i,j,t:integer;
begin
writeln('1:');
assign(f,'my.txt');
reset(f);
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
  read(f,a[i,j]);
  write(a[i,j]:3);
  end;
 readln(f);
 writeln;
 end;
close(f);
for i:=1 to n do
 for j:= i+1 to n do
 begin
  t:=a[i,j]; a[i,j]:=a[j,i]; a[j,i]:=t;
 end;
writeln('2:');
for i:=1 to n do
 begin
 for j:=1 to n do write(a[i,j]:3);
 writeln;
 end;
end.

Пример:
Файл my.txt:
23 28 19 23
34 14 8 14
44 20 14 48
38 47 20 41

Результат:
1:
23 28 19 23
34 14  8 14
44 20 14 48
38 47 20 41
2:
23 34 44 38
28 14 20 47
19  8 14 20
 23 14 48 41  
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота