Jelinad
30.05.2023 02:33

Написать программу к решению задачи. "Дана строка, содержащая путь к файлу. Выяснить название папки, в которой лежит файл." Пример. вход: C:\Мамины документы\Тесты и контрольные\7кл\годовая кр.doc
выход: 7кл

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sveto4ka342
26.10.2021 10:50

#include <iostream>

#include<vector>

using namespace std;

int square(int x){

for (int i = 1; i <= 45; ++i){

if (i * i <= x){

continue;

}

return (i - 1) * (i - 1);

}

}

int main()

{

int x, y, xwas, ywas, xywas;

cin >> x >> y;

xwas = square(x);

ywas = square(y);

xywas = square(x + y);

if (xwas + ywas < xywas){

cout << "Petya gives paint to Vasya";

}

else if (xwas + ywas == xywas){

cout << "Equal";

}

else {

cout << "Petya leaves paint to himself";

}

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
olivcad
15.10.2020 05:19

user_inputs = int(input('Введите месяц: '))

months = {

  1: 'январь',

  2: 'февраль',

  3: 'март',

  4: 'апрель',

  5: 'май',

  6: 'июнь',

  7: 'июль',

  8: 'август',

  9: 'сентябрь',

  10: 'октябрь',

  11: 'ноябрь',

  12: 'декабрь'

}

print(months.get(user_inputs))

age = int(input('Введите возраст: '))

if age > 80:

  print('Долгожители')

elif age <= 80 and age >= 56:

  print('Пожилые')

elif age <= 55 and age >= 30:

  print('Зрелые')

elif age <= 30 and age >= 17:

  print('Молодежь')

elif age <= 17 and age >= 7:

  print('Отрочество')

elif age <= 7 and age >= 3:

  print('Дошкольный период')

elif age <= 3 and age >= 1:

  print('Дошкольный период')

else:

  print('Error')

Объяснение:

Во втором задании ошибка. Дошкольный возрост не от 0 до 7 (т.к это бред условие не будет работать если одинаковые возрасты и для ясельного и для школьного) а с 3 до 7.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота