Slimede
25.03.2022 14:08

Составьте программу, котораясоставьте программу, которая заполняет массив а[1,,10 ] случайными числами в диапазоне от 0 до 10 , затем первый элемент меняет местами с максимальным элементом. выведите на экран исходный и полученный массивы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PineappleRomka
26.06.2020 08:26
uses crt;
const N=10;
var a:array [1..N] of integer;
    x,pos,max:integer;
begin
     randomize;
     for x:=1 to N do
     begin
         a[x]:=random(11);
         writeln('a[',x,']:',a[x]);
     end;
     max:=1;
     for x:=1 to N do
          if a[x]>a[max] then max:=x;
     pos:=a[1];
     a[1]:=a[max];
     a[max]:=pos;
     writeln;
     for x:=1 to N do
         writeln('a[',x,']:',a[x]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота