Zagonov
10.04.2021 22:35

Используя оператор for, написать программу в Паскале, которая вычисляет среднее арифметическое положительных чисел в промежутке от М до Р, где М>Р и М и Р положительные числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mihksy17
01.09.2022 11:09
Интернет – это средство информации и информационных ресурсов. Он имеет очень большое количество возможностей, которые в наше время широко используются.

1.Поиск информации. С интернета можно найти любого рода информацию. Для этого используют поисковые машины (поисковики). Эта система позволяет найти, например, любой товар и его цены по всему миру (например, серебряные украшения, пылесосы, автомобили – да что угодно!), поставщиков и рынки сбыта, узнать прогноз погоды и почитать новости. Можно также посмотреть с специальных программ на любой уголок земли.

2.Заработок в интернете. Зарабатывать деньги можно с сети, например, вкладывая денежные средства в биржи, также рекламируется различный заработок в сети. Что продавать и на чем заработать? Проследить за интересами и нуждами пользователей можно, благодаря зафиксированным последним запросам поисковиков. Что ищут юзеры стран СНГ? Узнайте сами: второе высшее образование,ювелирные изделия из серебра, прогноз погоды и т.д. Но к заработку в интернете нужно относиться очень осторожно, так как сегодня встречается множество мошенников. Существует большое количество коммерческих сайтов. За содержание такого рода сайта нужно платить деньги, поэтому большинство их направлены на получение прибыли (продажа, оказание услуг, размещение рекламы).

3.Получение информации. Скачать с интернета и перенести себе на компьютер можно различную информацию: любимую музыку, фильмы, игры, программы. Информацию большого объема нужно сначала закачать на свой компьютер, а затем с специальных программ открывать.

4.Обучение. Интернет используют как поддержку для получения образования. В нем можно найти обучающую информацию и программы, а также ответ на любой вопрос.

5.Развлечение. Набрав в поисковой системе слово «игры», откроются ссылки с огромным выбором развлекательных ресурсов. Найти также можно огромное количество интересных фотографий . Художники и писатели выкладывают свои работы на специальных форумах.

6.Общение. Интернет – это средство коммуникации. С социальных сетей, электронной почты, форумов можно общаться со всем миром. Эта система позволяет получать письма с другого конца земли в течение нескольких минут.

МОЖНО И КОРОЧЕ НАПИСАТЬ!
0,0(0 оценок)
Ответ:
СофариПарк3
24.01.2022 02:18
Program Shifr;
var    
  s1,s2,alf,key:string;
  i,n, Kod:integer;
  f1,f2:text;
BEGIN
alf:='';
assign(f1,'Dannie.txt'); 
assign(f2,'Shifr.txt'); 
reset(f1);
rewrite(f2);
writeln('Введите четырехзначный ключ шифрования:');
readln(key);
n:=0;
while Not(Eof(f1)) do
  begin
  readln(f1,s1);
  s2:='';
  for i:=1 to length(s1) do
    begin
    Kod:=Pos(s1[i],alf);
    n:=n+1;
    if n>4 then n:=1;
    Kod:=Kod+StrToInt(key[n]);
    if Kod>33 then Kod:=Kod-33;
    if Kod<1 then Kod:=Kod+33;
    s2:=s2+alf[Kod];
    end;
  writeln(f2,s2);
  end;
close(f1); 
close(f2); 
END. 

Program DeShifr;
var
  s1,s2,alf,key:string;
  i,n,Kod:integer;
  f1,f2:text;
BEGIN
alf:='';
assign(f1,'Shifr.txt'); 
assign(f2,'DeShifr.txt');
reset(f1);
rewrite(f2);
writeln('Введите четырехзначный ключ шифрования:');
readln(key);
n:=0;
while Not(Eof(f1)) do
  begin
  readln(f1,s1);
  s2:='';
  for i:=1 to length(s1) do
    begin
    Kod:=Pos(s1[i],alf);
    n:=n+1;
    if n>4 then n:=1;
    Kod:=Kod-StrToInt(key[n]);
    if Kod>33 then Kod:=Kod-33;
    if Kod<1 then Kod:=Kod+33;
    s2:=s2+alf[Kod];
    end;
  writeln(f2,s2);
  end;
close(f1); 
close(f2); 
END. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота