valetto
31.01.2022 12:42

Работа с матрицами. Составить программу на языке C (СИ) Создать квадратную матрицу целых чисел размером 9х9. В индивидуальных
заданиях указано, какую обработку матрицы требуется выполнить.
Если по условию задания матрицу следует заполнить случайными числами, рекомендуем
выбирать эти числа из диапазона 0 – 99. Если по условию задания в матрицу следует записать
ЛП — линейную последовательность чисел, имеется в виду последовательность: 1, 2, 3,
...


Работа с матрицами. Составить программу на языке C (СИ) Создать квадратную матрицу целых чисел разме

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Anili
24.12.2021 06:00

Відповідь:

include<stdio.h>

int main(){

unsigned int matrix[9][9]={0},a=1,b=8,t=1;

 

  for(int j=0;j<9;j++){

  for(int y=a;y<b;y++){

   matrix[y][j]=t;

   t++;

   

  }

  if(j>=0&&j<=3){

  a++;b--;}

  else{

  a--;b++;

  }}

 for(int i=0;i<9;i++){

  for(int j=0;j<9;j++){

   printf("%i\t",matrix[i][j]);

  }

  printf("\n");

 }

 

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота