saskey
11.09.2021 07:26

1. Известно, что в массиве с именем SLON содержится восемь целых чисел. Объявите
массив, если известно, что элементы нумеруются
с единицы.
2. Запишите значение элемента массива Т[4],
если массив сформирован следующим образом:
const T:array [1.5] of real=(1.3, -3.3, 6.4, 4.5, -
5.7);
3. Напишите значения элементов массива, если
его элементы были заданы следующим образом:
for i:=1 to 5 do a[i]:=i * 3 - 1;
4. Напишите команды заполнения
целочисленного массива V1, состоящего из 15
элементов, случайными числами, значения
которых изменяются в диапазоне от 0 до 32.
5. Запишите значения элементов массива,
сформированного следующим образом:
for i:=1 to 12 do
if i mod 4 = 0 then f[i]:=1/2 else f[i]:=1;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jutyra
30.01.2021 09:39

{Напишите программу, которая находит минимальное и максимальное

среди чётных положительных чисел, записанных в файле,

и выводит результат в другой файл.}

var f:text;

 min, max,a :integer;

 find:boolean;{есть/нет числа удовлетворяющие условию}

begin

 assign(f,'dan.txt'); reset(f);

 min:=0; max:=0;

 find:=false;

 while not eof(f) do

 begin

 read(f,a);

 if not find and (a>0) and (a mod 2=0) then

 begin

  min:=a; find:=true;

 end

 else

 if find and (a>0) and (a mod 2=0) and (min>a) then

  min:=a;

 if (a>0) and (a mod 2=0) and (max<a) then

  max:=a;

 end;

 close(f);

 assign(f,'res.txt');

 rewrite(f);

 if max=0 then writeln(f,'чётных положительных чисел нет')

 else

  writeln(f,'min среди чётных положительных чисел =',min, chr(13),

     'max среди чётных положительных чисел нет',max);

 close(f);

end.

Подробнее - на -

Объяснение:

0,0(0 оценок)
Ответ:
sasharyabukhina
30.01.2021 09:39
{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,'dan.txt'); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max<a) then
   max:=a;
 end;
 close(f);
 assign(f,'res.txt');
 rewrite(f);
 if max=0 then writeln(f,'чётных положительных чисел нет')
  else
   writeln(f,'min среди чётных положительных чисел =',min, chr(13),
      'max среди чётных положительных чисел нет',max);
  close(f);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота