qahhor
08.07.2022 11:20

Напишите программу на С++ Создать функцию типа void с передачей параметров по
ссылке или указателю, которая определяет длину отрезка
по его координатам. Для создаваемой функции необходимо
подобрать имя; выбрать имена и типы входных и выходных
параметров; описать тело функции; в главной программе
вызвать созданную подпрограмму более одного раза с
различными входными данными.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hiko35773
01.08.2022 04:41
Информация — от латинского слова "information", что означает сведения, разъяснения, изложение.                                                                       Информа́тика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.                                                                Программи́рование — процесс создания компьютерных программ.


0,0(0 оценок)
Ответ:
отличница446
25.11.2022 17:08

Цикл – это замечательное изобретение, которое, в сущности, и делает компьютеры такими ценными. Он позволяет многократно повторить любую часть программы. цикл не может выполняться вечно, он заканчивается по какому-либо условию. Проверка этого условия может производиться в начале каждого повторяющегося шага, в этом случае цикл называется ПОКА. При проверке условия в конце каждого шага цикл называется ДО. Разновидностью цикла ДО является цикл ПЕРЕСЧЕТ.

10.1.Оператор цикла WHILE (цикл ПОКА).

Формат оператора: WHILE логическое выражение DO;

Оператор будет повторятся пока истинно логическое выражение. Перед каждым повторением оператора значение логического выражения вычисляется заново. Если необходимо повторить несколько операторов, их следует объединить в составной оператор, т.е. заключить в операторные скобки begin … end. Этот цикл может не выполниться ни разу, если условие при входе в него оказалось ложным. Таким образом, цикл ПОКА содержит условие повторения цикла.

ПРИМЕР 1. Программа подсчета суммы S первых 1000 членов гармонического ряда

1+1/2+1/3+1/4+…1/N.

Program Summa;

Var S:real;

N:integer;

Begin

S:=0; N:=0;

While n<1000 do

Begin

N:=n+1;

S:=s+1/n

End;

Writeln(s);

Readln

End.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота