14569867
28.05.2023 16:04

Написать программу на языке C++ программа для вычисления одного или другого уравнения (z=8x-4; y=b^2-4ac, т.е. ветви «ДА» и «НЕТ»; если будет совпадать пароль 341)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Аринусик111
27.11.2022 13:27
//Pascal ABC.NET v3.1 сборка 1172

Var
 ar:array of integer;
 n,i,min,mini:integer;
begin
randomize;
min:=2147483647;
 writeln('Введите размерность:');
 readln(n);
 setlength(ar,n);
 writeln('Array:');
  for i:=0 to n-1 do
   begin
    ar[i]:=random(-30,30);
    write(ar[i]:4);
    if min>=ar[i] then
     begin
      min:=ar[i];
      mini:=i;
     end;
   end;
  for i:=0 to mini-1 do
   if ar[i]<0 then ar[i]:=0;
 writeln;
 writeln('Final array:');
  for i:=0 to n-1 do
   write(ar[i]:4);
end.

Пример ввода:
5
Пример вывода:
Array:
  -3 -26  -2  18 -21
Final array:
   0 -26  -2  18 -21
0,0(0 оценок)
Ответ:
Cammelia
21.01.2023 05:41
Ll - long long

dp[i] = dp[i-1] + dp[i-2] + dp[i-5] + dp[i-10];
ll dp[666];
dp[0] = 1;
for(int i=0;i<=64;i++)
{
dp[i+1]+=dp[i];
dp[i+2]+=dp[i];
dp[i+5]+=dp[i];
dp[i+10]+=dp[i];
cout << i << ": " << dp[i] << endl;
}
это если порядок важен, то есть 2 + 1 != 1 + 2, тогда ответ
489475342266653, наверное
а иначе 644

ll ans=0;
for(int i=0;i<10;i++) // 10
{
for(int j=0;j<20;j++) // 5
{
for(int k=0;k<50;k++) // 2
{
ll now = i*10 + j*5 + k*2;
if(now<=64) ans++;
}
}
}
cout << ans;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота