ez0lotareva
09.06.2021 22:03

Напишите программу, записывающую цвета разных песчаных морей. Формат ввода
Вводятся названия морей, пока не будет введена пустая строка. Потом вводится количество цветов песка, затем сами цвета.
Формат вывода
Для каждого моря через * запишите все цвета, с которыми у этого моря есть общие буквы, если не обращать внимание на регистр, и длины имеют не совпадающую четность. Цвета записывайте после названия моря через символ &, без повторений. Название моря большими буквами.
Если подходящих цветов для моря не нашлось, то его не выводить. Порядок вывода морей и цветов не важен.
Пример 1
Ввод Вывод
Red
Sandy
grassy
sea of grain

6
white
dark brick
yellowish
gray
volcanic
red

SEA OF GRAIN&red*yellowish*white
SANDY&dark brick*gray*volcanic
RED&dark brick*gray
GRASSY&yellowish*red

Пример 2
Ввод Вывод
mighty
tiny
Green

4
black
brown
pinkish
lemon

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pishinaangelina
11.01.2023 21:59

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

0,0(0 оценок)
Ответ:
ооиррррр
11.01.2023 21:59

Объяснение:

1.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

for thing in a:

   new_array.append(int(thing) * 2)

print(new_array)

2.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

new_array = []

last_elem = int(a.pop())

counter = 0

for thing in a:

   if counter == 0:

       new_array.append(int(thing))

       counter += 1

   else:

       new_array.append(int(thing) * 5)

new_array.append(last_elem)

print(new_array)

3.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

part = int(len(a) / 2)

new_array = []

for thing in a[:part]:

   new_array.append(int(thing) + 1)

for thing in a[part:]:

   new_array.append(int(thing) * 2)

print(new_array)

4.

a = input("Введите через запятую значения элементов массива (2,3,6...): ").split(",")

print(sum([int(number) for number in a]) / len(a))

5.

import random

numbers = range(-2, 3)

random_array = random.sample(numbers, random.randint(1, 4))

positive = [numb for numb in random_array if int(numb) > 0]

print(sum(positive))

6.

import random

numberss = range(2, 11)

numbers = random.sample(numberss, random.randint(1, 9))

d = {"Чётные": 0, "Нечётные": 0}

for thing in numbers:

   if int(thing) % 2 == 0:

       d["Чётные"] += 1

   else:

       d["Нечётные"] += 1

print(f"Масив: {numbers}")

print(", ".join([f"{v}: {d[v]}" for v in d]))

7. Не сильно понял задачу, можно объяснить по-подробнее?)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота