lerochek6
28.09.2020 15:06

Python с цикла while! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Abdurauf2004
17.12.2021 16:10

n = int(input())

maxc = -100000000

while n > 0:

   a = int(input())

   if a % 5 == 0:

       maxc = max(maxc,a)

   n -= 1

print(maxc)

0,0(0 оценок)
Ответ:
medovd
17.12.2021 16:10

x = int(input())

a = 0

z = 0

lel = ':)'

while a < x:

   a += 1

   f = int(input())

   if f%5:

       if lel == ':)':

           lel = f

       else:

           lel = max(lel,f)

print(lel)

Если есть вопросы, пиши

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота