Юлиандрv
11.08.2020 16:55

решить задачу через блок схему. Ввести одномерный массив А из N элементов. Всё элементы, чье значение, увеличенное на единицу и возведённое в квадрат, будет больше 50 , домножить на два. Массив вывести до и после преобразования.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
YUSUFOV
24.07.2022 03:13

1. На ленте машины Тьюринга содержится последовательностью символов “+”. Напишите программу для машины Тьюринга, которая каждый второй символ “+” заменит на “–”. Замена начинается с правого конца последовательности. Автомат в состоянии q1 обозревает один из символов указанной последовательности. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

2. Дано число n в восьмеричной системе счисления. Разработать машину Тьюринга, которая увеличивала бы заданное число n на 1. Автомат в состоянии q1 обозревает некую цифру входного слова. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

3. Дана десятичная запись натурального числа n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

4. Дано натуральное число n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1, при этом в выходном слове старшая цифра не должна быть 0. Например, если входным словом было “100”, то выходным словом должно быть “99”, а не “099”. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

5. Дан массив из открывающих и закрывающих скобок. Построить машину Тьюринга, которая удаляла бы пары взаимных скобок, т.е. расположенных подряд “( )”.

Например, дано “) ( ( ) ( ( )”, надо получить “) . . . ( ( ”.

Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

6. Дана строка из букв “a” и “b”. Разработать машину Тьюринга, которая переместит все буквы “a” в левую, а буквы “b” — в правую части строки. Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

0,0(0 оценок)
Ответ:
Элина1232456652
13.02.2022 04:32
// PascalABC.NET 3.2, сборка 1363 от 17.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var N:=ArrRandom(50,-111,348); N.Println;
  Writeln('Произведение элементов, кратных 5, равно ',
    N.Where(x->x mod 5=0).Aggregate(BigInteger(1),(a,b)->a*b));
  if N.Where(x->x.IsOdd).Count>N.Where(x->x.IsEven).Count then
    Writeln('Нечетных элементов больше')
  else Writeln('Четных элементов больше')
end.

Пример
151 129 60 55 140 -61 180 221 -7 1 -6 118 80 215 -109 176 82 265 209 234 36 276 71 147 268 138 288 300 37 270 290 79 -88 183 197 -13 23 222 -106 137 76 180 240 287 -55 -7 48 111 222 -82
Произведение элементов, кратных 5, равно -21155254513747200000000000000
Четных элементов больше
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота