domiks
03.06.2023 13:39

1) Напишите программу, которая находит
минимальный и максимальный из чётных элементов
массива. Гарантируется, что все элементы массива
находятся в диапазоне [-100;100] и среди них есть
хотя бы один чётный элемент.
2)Напишите программу, которая находит
минимальный и максимальный из элементов
массива, заканчивающихся на "5". Если в массиве
нет таких элементов, нужно вывести слово "нет".

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лераuse
06.02.2022 21:22

1)

a = [12,32,51,2,5,-10,-20,23,-23] # задаете любой массив

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 2 == 0:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 2 == 0:

       maxim = a[i]

       break

print(minim)

print(maxim)

2)

a = [12,32,51,2,1,-10,-20,21,-23]

a.sort()

minim = 0

maxim = 0

for i in range(len(a)):

   if a[i] % 10 == 5:

       minim = a[i]

       break

a = list(reversed(a))

for i in range(len(a)):

   if a[i] % 10 == 5:

       maxim = a[i]

       break

if minim == 0 and maxim == 0:

   print('No')

else:

   print(minim)

   print(maxim)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота