Eleonora20061
31.07.2020 21:01

Составить программу в pascal для нахождения корней квадратного уравнения ax^2+bx+c=0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mrarmen1999mailru
01.10.2020 13:27
Uses crt;
var
    d, a, b, c, x1, x2: real;

begin
    writeln('Введите a, b, c');
    readln(a, b, c);
    d := b * b - 4 * a * c;
    
    if d > 0 then
    begin
        x1 := (-b + sqrt(d)) / (2 * a);
        x2 := (-b - sqrt(d)) / (2 * a);
        writeln('x1 = ', x1:2:2);
        writeln('x2 = ', x2:2:2);
    end
    else if d = 0 then
    begin
        x1 := -b / (2 * a);
        writeln('x = ', x1:2:2);
    end
    else
        writeln('Нет действительных корней');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота