PolinaSenatorowa
23.06.2020 18:42

Написать программу, выполняющую сортировку массива, состоящего из 10 элементов, по возрастанию. Элементы массива взять равными (1, 3, -5, 2, 0, 6, 8, -3, -9, 5) паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
владимир203
21.01.2020 07:13
1.var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 

2. #include <stdafx.h> 
#include <stdio.h> 
#include <math.h> 
#include <stdlib.h> //for rand; 
int main()
 { 
int i, n,M[1]; 
 printf("Vvedit N:");
  scanf("%d",&n); 
for (i = 0; i < n; i++) 
 { 
  M[i] = rand()%10; 
    }
for (i = 0; i < n; i++) 
 { 
     printf("Array[%d] = %d\n", i, M[i]);
  } 
          scanf("%d"); 
return 0; 
}

3. var

a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]<min then min:=a[i];
writeln(min, ' - минимальне число.');

end. 

0,0(0 оценок)
Ответ:
Katylopy
21.01.2020 07:13
1.var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 

2. #include <stdafx.h> 
#include <stdio.h> 
#include <math.h> 
#include <stdlib.h> //for rand; 
int main()
 { 
int i, n,M[1]; 
 printf("Vvedit N:");
  scanf("%d",&n); 
for (i = 0; i < n; i++) 
 { 
  M[i] = rand()%10; 
    }
for (i = 0; i < n; i++) 
 { 
     printf("Array[%d] = %d\n", i, M[i]);
  } 
          scanf("%d"); 
return 0; 
}

3. var

a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]<min then min:=a[i];
writeln(min, ' - минимальне число.');

end. 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота