nastiarabadj
14.06.2022 16:05

1.Написать программу, которая подчитывает количество чисел, кратных , но некратных , в диапазоне от до А до B. ( FOR ) 2. Написать программу, вычисляющую количество месяцев, за которое спортсмен увеличит свою нагрузку в 2 раза. Спортсмен начинает тренировки с нагрузкой в кг, каждую неделю увеличивая на 0.1% от нормы предыдущей недели. (WHILE) 3. Пусть дано 100 целых чисел, которые вводятся по одному. Найти сумму нечетных отрицательных чисел. 4. Написать программу, которая проверяет – имеется ли в записи натурального числа ноль. 5.Пусть дано натуральное число n и вещественные числа a1, a2, a3,,…an, которые вводятся по одному. Найти a1+2a2+3a3+…+nan.

5. Даны n целых чисел, которые вводятся по одному. Определить количество чисел, которые больше заданного числа p

6.Даны n целых чисел, которые вводятся по одному. Определить количество чисел, которые оканчиваются на пять.

7.Даны n целых чисел, которые вводятся по одному. Определить количество чисел, которые попадают в промежуток [a,b].

8.Даны n вещественных чисел, которые вводятся по одному. Определить среднее арифметическое тех из них, которые больше 10

9. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти количество всех четных чисел последовательности

10.Даны n вещественных чисел, которые вводятся по одному. Определить среднее арифметическое тех из них, которые меньше 10

11. Даны n целых чисел, которые вводятся по одному. Определить количество чисел, которые оканчиваются на три

12. Написать программу, которая проверяет – имеется ли в записи натурального числа 4?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
андрюха87
04.02.2022 15:47

1)

a = int(input())

b = int(input())

for i in range(a, b+1):

   if i % ... == 0 and i % ... != 0:

       ...

print(...)

2)

a = int(input())

x = a*2

n = 0

while a < x:

   a = a + (a * 0.1)

   n += 1

print(n/4)

3)

sum = 0

for i in range(100):

   a = int(input())

   if a < 0 and a % 2 != 0:

       sum += a

print(a)

4)

a = input()

if a.count('0') != 0:

   print('est`')

else:

   print('net')

5)

p = int(input())

n = int(input())

c = 0

for i in range(n):

   a = int(input())

   if a > p:

       c += 1

print(c)

6)

n = int(input())

c = 0

for i in range(n):

   a = int(input())

   if a % 10 == 5:

       c += 1

print(c)

7)

a = int(input())

b = int(input())

n = int(input())

c = 0

for i in range(n):

   x = int(input())

   if a <= x <= b:

       c += 1

print(c)

8)

n = int(input())

c = 0

sum = 0

for i in range(n):

   x = float(input())

   if x > 10:

       sum += x

       c += 1

print(x / c)

9)

c = 0

while True:

   a = int(input())

   if a == 0:

       break

   if a % 2 == 0:

       c += 1

print(c)

10)

n = int(input())

c = 0

sum = 0

for i in range(n):

   x = float(input())

   if x < 10:

       sum += x

       c += 1

print(x / c)

11)

n = int(input())

c = 0

for i in range(n):

   x = int(input())

   if x % 10 == 3:

       c += 1

print(c)

12)

x = input()

if x.count('4') != 0:

   print('yes')

else:

   print('no')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота