almira666ozs336
16.03.2023 05:26

1 задачу напишите на каком языке программирования вы писали: D. Равенство строк
Ограничение времени 1 секунда
Ограничение памяти 64.0 Мб
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Вася получил две строки
s
s и
t
t длины
n
n каждая. Он хочет написать программу, которая проверит, равны ли эти строки.

Язык программирования, на котором пишет Вася, не имеет инструкции для сравнения строк, зато разрешает проверить два символа на равенство. Вася планирует брать произвольный индекс

i
i, не встречавшийся ранее, после чего проверять на равенство символы

s
i
s
i

и
t
i
t
i

. Как только Вася встретит пару различных символов, он прервет выполнение программы, потому что строки уже гарантированно не равны друг другу. Если все индексы были рассмотрены, программа Васи заканчивает выполнение.

От вас требуется определить, через сколько шагов программа Васи гарантированно остановится.

Формат ввода
В двух строках вводятся строки
s
,
t
s,t из строчных латинских букв

(
1
≤
∣
s
∣
,
∣
t
∣
≤
1000
)
(1≤∣s∣,∣t∣≤1000) , где
∣
s
∣
∣s∣ - длина строки
s
s.

Формат вывода
Выведите одно число -− максимальное число шагов, которое сделает программа Васи.

Пример
Ввод Вывод
abcd
axcx
3
Примечания
В примере программа Васи может сделать три шага, если проверит на равенство сначала символы « a» , потом символы « c», а потом остановится после проверки пары символов « b» или « x»

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
braununs
25.07.2021 06:37
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
0,0(0 оценок)
Ответ:
Iruna131
03.08.2020 08:07
3 Информация - совокупность сведений, знаний о чем-либо; сообщение - совокупность знаков , отображающих информацию.
4 Кодирование - зашифровка информации (перевод языка на азбуку Морзе),декодирование - расшифровка( расшифровка сообщения с азбуки Морзе,к примеру, на русский язык).
5 Кол-во информации предотвращает неопределенность.Неопределенность информации характеризуется энтропией, хаосом.
6 Актуализация информации - совокупность действий по обновлению, расширению, восстановлению информации для эффективности  ее использования.
7 Актуальность, полнота, доступность,понятность (т.е. понятна для восприятия) 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота