huilo4
30.11.2020 22:20

Нужно составить программу на python! Также решить задачу.


Нужно составить программу на python! Также решить задачу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
milenairk38
24.11.2020 09:37
1. Разностная машина Беббиджа должна была заменить группу вычислителей, которые аккуратно склвдывали и вычитали числа. Поэтому утверждение "Б" - справедливо
2. Подготовка данных с перфокарт, утверждение "А" - справедливо.
3. Утверждение "Г" - спорно, хотя в 2000 году в лондонском Музее науки заработал принтер, придуманный Бэббиджем для своей машины.

Вообще машина проектировалась как механический аппарат предназначенный для автоматизации вычислений путем аппроксимации функций многочленами и вычисления конечных разностей.
0,0(0 оценок)
Ответ:
wwwOli6578000
14.07.2022 00:45
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=5;

Var
 ma:array[1..n,1..n] of integer;
 i,j,max,maxj,a:integer;
begin
max:=-1;
randomize;
 writeln('Matrix:');
  for i:=1 to n do
   begin;
   for j:=1 to n do
    begin;
     ma[i,j]:=random(10);
     write(ma[i,j]:4);
    end;
   writeln;
   end;
  for j:=1 to n do
  begin
   for i:=1 to n do
     a:=a+ma[i,j];
   if a>max then
    begin
     max:=a;
     maxj:=j;
    end;
    a:=0;
  end;
write('Максимальный по сумме столбец:',maxj);
end.

Пример работы кода:
Matrix:
   8   6   8   0   2
   6   1   2   9   8
   8   1   8   0   1
   4   5   1   5   2
   3   0   9   9   5
Максимальный по сумме столбец:1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота