user15042001
27.04.2020 06:26

Составьте программу вычисления в одномерном массиве минимального элемента и его номера.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
donatas6969
01.10.2020 13:26
1)
var
a: array [1..100] of longint;
i,j,k,n:longint;
begin
readln(n);
for i:=1 to n do readln(a[i]);
k:=a[1]; j:=1;
for i:=1 to n do
  if a[i]<k then begin k:=a[i]; j:=i; end;
writeln(k, '  ',j);
end.
0,0(0 оценок)
Ответ:
jcgddrMarins
01.10.2020 13:26
Uses crt;
const N=10;
var a:array [1..N] of integer;
    x,y,min:integer;
begin
     for x:=1 to N do
     begin
          write('a[',x,']:');
          readln(a[x]);
     end;
     min:=a[1];
     y:=1;
     for x:=1 to N do
     if a[x]<min then
     begin
          min:=a[x];
          y:=x;
     end;
     writeln('min[',y,']:',min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота