вера731
16.09.2020 17:02

написать программу на Delfi Задание: Нахождение минимального значения среди последовательности вводимых чисел. Сам признак конца при определении минимума не учитывать.
Остановить обработку при вводе признака конца – предварительно введенного пользователем числа из диапазона -10..5
Тип обработки данных целых

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hlebushek225
11.10.2022 10:03
Здесь нужно использовать вс типизированный файл и, соответственно, вторую файловую переменную (fr2).
Сделать это можно так:
while not eof(fr) and (kol=0) do
begin
read(fr, Marshrut);
if (Marshrut.NK.N <> '11')
   then write(fr2,Marshrut)
   else begin inc(kol); y:=Marshrut; end;
end;
if not eof(fr) then
  begin
  read(fr, Marshrut);
  write(fr2,Marshrut);
  end;
if (kol=1) then  write(fr2,y);
Дальше нужно просто переписать оставшиеся записи из первого файла во второй. Затем оба файла закрыть, первый файл удалить, а второй переименовать (т.е. назвать его так, как назывался первый файл).

Попробуйте ещё вот такой вариант:
(здесь k1 и k2 - целые, а y - типа )
if (Marshrut.NK.N = '11') then
begin
writeln('... ');
inc(kol);
y:=Marshrut;
k1:=FilePos(fr)-1;
k2:=FilePos(fr);
if not eof(fr) then
 begin
 read(fr, Marshrut);
 seek (fr, k1);
 write(fr, Marshrut);
 seek (fr, k2);
 write (fr, y);
 end;

end;
0,0(0 оценок)
Ответ:
777495
23.02.2021 21:50
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота