LerkaKsuphaMey
18.04.2021 14:21

Дан массив D[15], заполненный целыми числами из диапазона от 1000 до 2000. Написать программу, которая будет заменять элементы массива с нечетными номерами на квадраты этих элементов ОЧЕНЬ !
через паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Котполиглот
23.09.2021 09:29
1)
#include <iostream>
using namespace std;

int main()
{
    int n;
    cout << "n = ", cin >> n;
    for (int i=10; i<100; i++) {
    if ((i/10==n)||(i%10==n)||(i%n==0))
       cout << i << " ";
    }
    return 0;
}

Пример:
n = 7
14 17 21 27 28 35 37 42 47 49 56 57 63 67 70 71 72 73 74 75 76 77 78 79 84 87 91 97 98

2.
#include <iostream>
using namespace std;

int main()
{
    for (int i=1; i<10; i++) {
    for (int j=0; j<10; j++)
       cout << i*100+j*10+i << " ";
    }
    return 0;
}

Результат:
101 111 121 131 ... 979 989 999

3.
#include <iostream>
using namespace std;

int main()
{
    int s = 0;
    for (int i=10; i<100; i++) {
    if ((i % 2 == 0)||(i % 10 == 7)) s +=i;
    }
    cout << "s = " << s;
    return 0;
}

Результат:
s = 2943

4.
#include <iostream>
using namespace std;

int main()
{
    int a, b, c, k = 0;
    for (int i=100; i<1000; i++) {
    a = i / 100;
    b = i / 10 % 10;
    c = i % 10;
    if ((a==b)||(a==c)||(b==c)) k++;
    }
    cout << "k = " << k;
    return 0;
}

Результат:
k = 252
0,0(0 оценок)
Ответ:
djastin05
27.06.2022 18:50
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  // 1
  var a:=ArrRandom(100,-20,20); a.Println;
  a.Where(x->x>5).Println;
  // 2
  var b:=ArrRandom(10,-50,50); b.Println;
  Writeln(b.Average);
  // 3
  var c:=ArrRandom(10,-30,30); c.Println;
  var d:=c.Select(x->x*x); d.Println
end.

Пример
3 0 -2 4 17 8 20 -1 -20 18 -6 -9 4 15 -18 -8 0 -17 3 -19 16 -7 -8 16 -19 11 20 2 12 -3 8 9 -13 20 1 1 13 9 15 15 -7 -16 8 13 -3 -9 -16 -17 7 5 -15 -13 18 -16 -1 -11 -13 2 2 -14 9 -3 7 3 -11 6 -16 4 -6 1 -1 11 -11 8 9 11 5 0 -2 10 6 16 16 -13 -8 1 11 -17 1 -9 -6 -10 -14 8 -14 16 -2 -15 4 12
17 8 20 18 15 16 16 11 20 12 8 9 20 13 9 15 15 8 13 7 18 9 7 6 11 8 9 11 10 6 16 16 11 8 16 12
-32 1 24 -36 -37 -14 45 -26 -11 20
-6.6
6 11 -25 19 1 19 3 0 -14 13
36 121 625 361 1 361 9 0 196 169
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота