RassvetZaGorami
27.08.2022 11:38

ВАРИАНТ 6 1. Дан одномерный массив а из шести элементов: -125 11 200 10 1) Как объявить этот массив в программе, записанной на языке Питон? 2) Чему равно значение элемента массива с индексом 4? 3) Чему равно значение элемента массива a[a [4]] ? 2. Программа обрабатывает одномерный делочисленный мас- сив Dat: 1 1 2 5 6 7 8 9 10 Dat [1] 70 80 40 40 70 80 90 Заполните трассировочную таблицу и определите, какие числа будут выведены в результате выполнения следую- щего фрагмента программы. k : 1; k m i dat[i] (ЭТО ТОЖЕ В ПИТОНЕ!)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Grisha7089
18.09.2021 01:13
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
const
  n=5;
type
  Matrix=array[1..n,1..n] of integer;

procedure DummySchool(var a:Matrix);
begin
  Writeln('Ввод элементов матрицы');
  for var i:=1 to n do begin
    Write(n,' элементов строки ',i,': ');
    for var j:=1 to n do Read(a[i,j]);
    end;
  Writeln('Сформирована матрица ',n,'x',n);
  for var i:=1 to n do begin
    for var j:=1 to n do Write(a[i,j]:5);
    Writeln
    end
end;

begin
  var B:Matrix;
  DummySchool(B);
  var sn:=0;
  var sp:=0;
  for var i:=1 to n do
    for var j:=1 to n do
      if B[i,j]<0 then sn+=B[i,j]
      else
        if B[i,j]>0 then sp+=B[i,j];
  Writeln('Сумма отрицательных ',sn);
  Writeln('Сумма положительных ',sp)
end.

Тестовое решение:
Ввод элементов матрицы
5 элементов строки 1: 6 23 -5 13 9
5 элементов строки 2: 42 0 -38 16 37
5 элементов строки 3: -5 -18 3 11 8
5 элементов строки 4: 9 13 -11 0 3
5 элементов строки 5: 19 -17 0 15 5
Сформирована матрица 5x5
    6   23   -5   13    9
   42    0  -38   16   37
   -5  -18    3   11    8
    9   13  -11    0    3
   19  -17    0   15    5
Сумма отрицательных -94
Сумма положительных 232
0,0(0 оценок)
Ответ:
00099000
05.02.2021 21:42
Сейчас в мире развиваются новые технологии. Сейчас книги не пишут в ручную, а печатают на компьютере. Нам сложно прожить без интернета "каждый день мы ищем там интересную информацию, узнаем новое, смотрим фильмы, учимся".Кто то зарабатывает в интернете. Мне кажется что информатику нужно изучать для того чтобы в будущем мы были развиты в компьютерных технологиях и умели работать за компьютером. Потому что учителя, работники офисов, врачи и еще много профессий зависят от компьютеров, а информатика учит нас быть с компьютерами на ты.
.
P.S. писал сам)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота