снежана1281
10.09.2021 16:33

Написать программу на языке Pascal для решения задачи: а) Ввести случайным образом (возможные значения от 0 до 60) значения 7 элементов массива, содержащего целые числа. Значение каждого элемента массива уменьшить на 10. Вывести значения элементов измененного массива на экран в строчку (через пробел).
б) Ввести с клавиатуры значения 15 элементов массива, содержащего вещественные числа. Значение каждого элемента массива увеличить в 4 раза. Вывести значения элементов измененного массива на экран в столбик.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Erikalallala
24.12.2021 05:56

QPython+SL4A:

import android

import time

import sys, select, os #for loop exit

#Initiate android-module

droid = android.Android()

#notify me

droid.makeToast("fetching GPS data")

print("start gps-sensor...")

droid.startLocating()

while True:

   #exit loop hook

   if sys.stdin in select.select([sys.stdin], [], [], 0)[0]:

       line = input()

       print("exit endless loop...")

       break

   #wait for location-event

   event = droid.eventWaitFor('location',10000).result

   if event['name'] == "location":

       try:

           #try to get gps location data

           timestamp = repr(event['data']['gps']['time'])

           longitude = repr(event['data']['gps']['longitude'])

           latitude = repr(event['data']['gps']['latitude'])

           altitude = repr(event['data']['gps']['altitude'])

           speed = repr(event['data']['gps']['speed'])

           accuracy = repr(event['data']['gps']['accuracy'])

           loctype = "gps"

       except KeyError:

           #if no gps data, get the network location instead (inaccurate)

           timestamp = repr(event['data']['network']['time'])

           longitude = repr(event['data']['network']['longitude'])

           latitude = repr(event['data']['network']['latitude'])

           altitude = repr(event['data']['network']['altitude'])

           speed = repr(event['data']['network']['speed'])

           accuracy = repr(event['data']['network']['accuracy'])

           loctype = "net"

       data = loctype + ";" + timestamp + ";" + longitude + ";" + latitude + ";" + altitude + ";" + speed + ";" + accuracy

   print(data) #logging

   time.sleep(5) #wait for 5 seconds

print("stop gps-sensor...")

droid.stopLocating()

0,0(0 оценок)
Ответ:
Анастасия0000000000
04.11.2022 14:21

Конус – это тело, образованное совокупностью всех лучей, исходящих из точки и пересекающих плоскость.

Точка, из которой лучи исходят, получила название вершины конуса. В случае, когда основанием конуса является многоугольник, он превращается в пирамиду.

Рассмотрим некоторые важные понятия.

Образующей конуса называется отрезок, который соединяет любую точку границы основания конуса, с его вершиной.

Высотой конуса является перпендикуляр, который опущен из вершины к основанию тела.

Конус бывает нескольких типов:

Прямой, если его основание – одна из таких фигур, как эллипс или круг. Обязательным условием является проецирование вершины конуса в центр основания.

Косой – у него центр фигуры, которая находится в основании, не совпадает с проекцией вершины на это самое основание.

Круговой – отталкиваясь от названия, понятно, что в его основании лежит круг.

Усеченный – область конуса, лежащая между основанием и сечением плоскости, которая параллельна основанию и пересекает данный конус.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота