sanekmmg1980
28.06.2020 10:55

Позвольте быть матрица A (n, m) с целыми числами. Напишите программу, которая будет определять и отображать, сколько минимальных элементов появляется. pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vladgodd
06.08.2020 12:22
Function Intg(p, b: real; n: integer; eps: real): real;
{Метод прямоугольников, рекурсия}
var
  a, x, h, s: real;
  i: integer;
begin
  a := 0;
  h := (b - a) / n;
  x := a;
  s := 0;
  for i := 1 to n do
  begin
    s := s + sin(x);
    x := x + h;
  end;
  if abs(s * h - p) > eps then
    Intg := Intg(s * h, b, 2 * n, eps)
  else
    Intg := s * h;
end;

var
  b, eps: real;

begin
  write('Задайте верхний предел интегрирования и точность: ');
  Readln(b, eps);
  writeln('Значение интеграла: ', Intg(0, b, 2, eps):0:7);
end.

Тестовое решение:

Задайте верхний предел интегрирования и точность: 2 0.000001
Значение интеграла: 1.4161460

Точное значение интеграла равно 1-cos(2) ≈1.416146836, т.е. заданная точность обеспечивается.
0,0(0 оценок)
Ответ:
nadechdavasilev
06.08.2020 12:22
Можно заметить, что самый большой угол в треугольнике всегда расположен напротив самой длинной стороны, которую мы обозначим буквой с.
Значение такого угла можно найти по теореме косинусов:
\displaystyle \cos(C)= \frac{a^2+b^2-c^2}{2ab}
В остроугольном треугольнике угол всегда будет меньше 90 градусов, поэтому его косинус всегда будет положительным. В прямоугольном треугольнике косинус будет равен нулю, а в тупоугольном он будет отрицательным. На этом можно построить решение, предварительно определив, какая из сторон является самой длинной. И, само собой разумеется, надо сразу после ввода проверить условие существования треугольника, т.е. чтобы сумма длин двух его любых сторон была больше третьей.

var
  a,b,c,a1,b1,c1,cosC:real;
begin
  Write('Введите длины сторон треугольника: ');
  Read(a,b,c);
  Write('Треугольник ');
  if (a<(b+c)) and (b<(a+c)) and (c<(a+b)) then begin
    if a>b then
      if a>c then begin c1:=a; a1:=c; b1:=b end
      else begin c1:=c; a1:=a; b1:=b end
    else
      if b>c then begin c1:=b; a1:=a; b1:=c end
      else begin c1:=c; a1:=a; b1:=b end;
    cosC:=(sqr(a1)+sqr(b1)-sqr(c1))/(2*a*b);
    if cosC<0 then Writeln('тупоугольный')
    else
      if cosC=0 then Writeln('прямоугольный')
      else Writeln('остроугольный')
  end
  else Writeln('построить невозможно')
end.

Тестовое решение:
Введите длины сторон треугольника: 6 4.1 4
Треугольник тупоугольный
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота