Сильнолол
03.01.2021 05:15

Написать программу на питоне, используя двумерные массивы Дана квадратная матрица A порядка M. Найти сумму элементов каждой ее диагонали.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Olesyalesya55
15.11.2021 00:11

#include <iostream>


using namespace std;


void print_array(int* array, int size)

{

for(int i = 0;i<size;i++)

{

cout << array[i] << "\t";

}

cout << endl;

}


int main(int argc, char** argv) {

int n;

cout << "Введите количество элементов в массиве: ";

cin >> n;

int* array = new int[n];

int* copy = new int[n];

for(int i = 0;i<n;i++)

{

cout << "Введите элемент ["<< i <<"]: ";

int number;

cin >> number;

array[i] = number;

if(number < 0)number = -number;

copy[i] = number < 10 ? number : 0;

}

cout << "До: ";

print_array(array,n);

cout << "После: ";

print_array(copy,n);

delete[] array;

delete[] copy;

return 0;

}

0,0(0 оценок)
Ответ:
адинаева
15.04.2023 05:52

1. Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.

2. Свойства: Субъективность информации.

Достоверность информации.

Полнота информации.

Точность информации.

Актуальность информации

Полезность (ценность) информации.

3. Информационная система — система, предназначенная для хранения, поиска и обработки информации, и соответствующие организационные ресурсы, которые обеспечивают и распространяют информацию.

4. Кодирование информации – это процесс формирования определенного представления информации. Бит – наименьшая единица представления информации. Байт – наименьшая единица обработки и передачи информации. В информатике часто используется величина, называемая байтом (byte) и равная 8 битам. И если бит позволяет выбрать один вариант из двух возможных, то байт, соответственно, 1 из 256 (28). Наряду с байтами для измерения количества информации используются более крупные единицы:

1 Кбайт (один килобайт) = 210 байт = 1024 байта;

1 Мбайт (один мегабайт) = 210 Кбайт = 1024 Кбайта;

1 Гбайт (один гигабайт) = 210 Мбайт = 1024 Мбайта.

5. Текстовую информацию кодируют двоичным кодом через обозначение каждого символа алфавита определенным целым числом.

6. Есть два кодирования графической информации. В растровой графике изображение в процессе кодирования разбивается на маленькие точки или пиксели. Каждому пикселю присваивается код его цвета вместе. Информация о каждой такой точке содержит компьютерная видеопамять. Векторная графика создается из примитивных объектов таких как линия, кривая, точка, прямоугольник, треугольник, окружность.

Эти элементы и их объём описываются с математических формул.

7. В основе кодирования звука с использованием ПК лежит процесс преобразования колебаний воздуха в колебания электрического тока и последующая дискретизация аналогового электрического сигнала.

8. Для записи информации о количестве объектов используются числа. Числа записываются с использованием особых знаковых систем, которые называются системами счисления. Алфавит систем счисления состоит из символов, которые называются цифрами. Знаменитый ученый Лейбниц предложил еще в XVII веке уникальную и простую систему представления чисел. Сегодня такой представления информации с языка, содержащего всего два символа алфавита – 0 и 1, широко используется в технических устройствах. Как раз в компьютере используется такая система счисления, которая называется двоичной.

Для кодирования чисел используются специальные правила перевода чисел из десятичной системы счисления в другие системы счисления и наоборот.

9. Слепой метод набора — методика набора текста не глядя на клавиши клавиатуры, используя все (или большинство) пальцы рук. Физическое здоровье — осанка, зрение (избавляет от сутулости, позволяет разместить клавиатуру и монитор в удобные для такой работы места, в частности поместить монитор на оптимальное для глаз расстояние). Достоинства:

Психическая утомляемость (меньше умственных усилий на набор текста и выполнение необходимой работы, меньше ошибок и связанного с ними раздражения)

Гораздо более высокая производительность. Высвобождение возможностей для более эффективного выполнения большего количества и объёма задач.

Недостатки: Много опечаток, привязан к раскладке определенного языка.

10. Логика 1. Наука о законах мышления и его формах. 2. Ход рассуждений, умозаключений.

Высказывание предложение, которое может быть истинно или ложно.

Утверждение - положение, мысль, к-рой доказывают, утверждают что-н.

Рассуждение - Умозаключение, ряд мыслей, изложенных в логически последовательной форме.

Умозаключение – процедура выведения некоторого высказывания из одного или нескольких высказываний.

Логическое выражение — конструкция языка программирования, результатом вычисления которой является «истина» или «ложь».

11. См. прикрепленное изображениею



Вопросы для подготовки к зачету: теоретические вопросы 1. информатика: понятие. 2. свойства информац
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота