emma66669
17.06.2022 21:59

Написать программу, определяющую, как соотносятся между собой два произвольных числа А и В. Рекомендация: при решении используется вложенное ветвление. Ниже приведен фрагмент алгоритма:


Написать программу, определяющую, как соотносятся между собой два произвольных числа А и В. Рекоменд

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
милана198026
13.01.2022 19:10

#include <iostream>

using namespace std;

int main() {

   int n;

   cin >> n;

   int mass[];

   for (int i = 0; i < n; i++) {

   cin >> mass[i];

   }

   int count_0 = 0, count_pol = 0, count_otr = 0;

   for (int i = 0; i < n; i++) {

   if (mass[i] == 0) {

       count_0++;

   }

   if (mass[i] > 0) {

       count_pol++;

   }

   if (mass[i] < 0) {

       count_otr++;

   }

   }

   cout << count_0 << " " << count_pol << " " <<count_otr;

   cout <<endl;

   system ("pause");

   return 0;

}

0,0(0 оценок)
Ответ:
daurova2007
13.01.2022 19:10

var

 i, n, ch, k1, k2, k3: Integer; //Объявляем переменные

begin // Начало блока  

 Writeln('Введите кол-во чисел: '); Readln(n); //В переменную N записываем информацию о количестве чисел

 Writeln('Введите числа: ');

 for i := 1 to n do // Начинаем цикл for от 1 до N                                  

 begin //Начало цикла

   Readln(ch); //Записываем в переменную CH информацию о числе введеного с клавиатуры

   {Inc - счетчик  

   т.е если условие истинно с

   мы в переменную k1 записываем +1}

   if ch = 0 Then Inc(k1);  

   if ch > 0 Then Inc(k2);

   if ch < 0 Then Inc(k3);

 end; //Конец цикла

 {Выводим информацию о количестве чисел которые соответствуют условию}

 Writeln('Число нулей: ', k1);  

 Writeln('Число положительных: ', k2);

 Writeln('Число отрицательных: ', k3);

end. // Конец

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота