кира631
26.11.2021 13:36

Составить программу для решения следующей : дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. замените все отрицательные элементы максимальным. выведите на экран исходный и измененный массивы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fsjxjnlsjaCn
25.06.2020 17:59
var
i,max:integer;
ar:array[0..200] of integer;

begin
randomize;
max:=0;

for i:=1 to 200 do begin
ar[i]:=random(200+1)-100;
if (ar[i] > max) then max:=ar[i];
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' ');
end;

writeln();

for i:=1 to 200 do begin 
if (ar[i] < 0) then ar[i]:=max; 
if (i mod 20=0) then writeln(ar[i]) else write(ar[i],' '); 
end;

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота