ailonkilo
20.02.2021 14:45

ПО ИНФОРМАТИКЕ, ПРОГРАММА PASCAL. Вот задания:
1.Ввести два числа. Если их разность больше 24, то вывести модуль их частного, если нет - квадрат произведения.
2.Написать программу для вычисления:
Z=5Y/16 , если у ≤ 0
16/5Y , если у > 0, где у = 2х +3
3.Ввести число. Если оно неотрицательное, то найти и вывести на печать корень из этого числа, его куб и его разницу с числом 15, если нет – его квадрат, модуль и разность его 4-й степени с числом 100.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
karinakovalenko2
30.10.2021 05:56

1.

#include <iostream>

using namespace std;

int main()

{

for (int i = 2; i <= 100; i += 2)

 cout << i << "  ";

}

2.

С использованием арифметической прогрессии

#include <iostream>

using namespace std;

int main()

{

cout << ((1 + 50) * 50) / 2;

}

Решение "в лоб"

#include <iostream>

using namespace std;

int main()

{

int sum = 0;

for (int i = 1; i <= 50; i++)

 sum += i;

cout << sum;

}

3.

#include <iostream>

using namespace std;

int main()

{

int sum = 0;

for (int i = 1000; i >= 0; i--)

 cout << i << "  ";

cout << "\n Hello World";

}

4.

#include <iostream>

using namespace std;

int main()

{

int a, b;

cin >> a >> b;

if (a > b)

 for (int i = a; i >= b; i--)

  cout << i << "  ";

else

 for (int i = b; i >= a; i--)

  cout << i << "  ";

}

0,0(0 оценок)
Ответ:
astraelenap01fez
24.06.2021 07:40

Объяснение:

program n_05;

   var a, b, c, f: integer;

begin

   f:=0;

   writeln ('Программа поиска делящихся на 5 чисел');

   write ('Введите три произвольных числа >>');

   readln (a,b,c);

   if (a mod 10 in [0,5]) then

       begin

           writeln (a);

           f := 1;

       end;

   if (b mod 10 in [0,5]) then

       begin    

           writeln (b);

           f := 1;

       end;

   if (c mod 10 in [0,5]) then

       begin

           writeln (c);

           f := 1;

       end;

   writeln ('f',f);

   if (f=0) then

       writeln('нет чисел, делящихся на 5');

end.

Неизящно. Может быть кто-то предложит вариант лучше без флажков или без if.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота