pollyyyyyyyyyyy
28.04.2022 20:14

Составьте программу для массива состоящего из N целых чисел. Ввод каждого значения массива осуществляется случайным образом, значения из интервала (-100;50). Осуществите вывод элементов массива. Вычислите сумму чётных номеров массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dimapavlov2007
25.01.2022 00:16
Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin      
If Random(2) = 1 Then
SunnyDay[i] := True
Else
SunnyDay[i] := False;
End;
For i := 1 To 30 Do
Begin  
If SunnyDay[i] = True
ThenBegin    
a := a + 2;    
If a > b Then    
a := b;  
End  
Else  
Begin   
a := a - 10;    
If a < 0 Then    
a := 0;  End;  
End; WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do
Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный')
End;
WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
End.
0,0(0 оценок)
Ответ:
rozettak
28.08.2022 16:26
1.
program n_1;
var a, b : string; i, s, n: integer;
begin
n:=0;
repeat
writeln('Введите слово');
readln(a);
s:=length(a);
for i:=1 to s do
begin
if a[i]='' then n:=n+1
end;
if n>=2 then b:=b+' '+a;
writeln('Слово',b);
writeln('Количество букв: ', n);
end.
program abc;
var a:string; z, i, k, l m, n: integer;
begin
k:=0;
l:=0;
m:=0;
n:=0;
writeln('Введите слово');
readln(a);
z:=length(a);
for i:=1 to z do
begin
if a[i]='Щ' then k:=k+1 else
if a[i]='Ц' then l:=l+1 else
if a[i]='Ы' then n:=n+1 else m:=m+1;
end;
writeln('Щ', k, 'Ц', l, 'Ы', n, 'О', m);
end.
это на нахождение двойных букв
program chet;
var a, l: string; s, i: integer;
begin
repeat
writeln('Введите слово');
readln(a);
s:=length(a);
for i:=1 to s do
if a[i]=a[i+1] then l:l+' '+a;
until a>' ';
writeln(l);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота