eminka1
22.06.2022 08:49

дан список чисел. Напишите программу выводящую на экран числа которые больше предыдущих

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lanamalinena
21.09.2020 04:01

s = inptu()

for i in range(len(s)):

   if s[i]== 'а' or 'е' or 'ё' or 'и' or 'о' or 'у' or 'ы' or 'э' or 'ю' or 'я':

       g += 1

   if s[i]== 'й' or 'ц' or 'к' or 'н' or 'г' or 'ш' or 'щ' or 'з' or 'х' or 'ф' or 'в' or 'п' or 'р' or 'л' or 'д' or 'ж' or 'ч' or 'с' or 'м' or 'т' or 'б':

       sg += 1

       

   if s[i]== 'А' or 'Е' or 'Ё' or 'И' or 'О' or 'У' or 'Ы' or 'Э' or 'Ю' or 'Я':

       g += 1

   if s[i]== 'Й' or 'Ц' or 'У' or 'Н' or 'Г' or 'Ш' or 'Щ' or 'З' or 'Х' or 'Ф' or 'В' or 'П' or 'Р' or 'Л' or 'Д' or 'Ж' or 'Ч' or 'С' or 'М' or 'Т' or 'Б':

       sg += 1

print('Гласных: ',g)

print('Согласных: ',sg)

Объяснение:

0,0(0 оценок)
Ответ:
Shanmao
12.10.2020 06:15

const

 n = 100; {максимальное число элементов в массиве}

 b = -32768;{константа для заливки массивов }

type

 tF = array[1..n] of integer;

function l(f: tF): integer;

var

 i, k: integer;

begin

 k := 0;

 l := n;

 for i := 1 to n do

   if f[i] = b then

   begin

     l := i - 1;

     exit

   end;

 k := k + 1;

end;

var

 i, k, p1, p2: integer;

 f1, f2, f3, f4: tF;

 s: string[2];

begin

 { заполним все массивы константой b }

 { если при чтении массива константа b, все элементы прочтены }

 for i := 1 to n do

 begin

   f1[i] := b;

   f2[i] := b;

   f3[i] := b;

   f4[i] := b;

 end;

 randomize;

 { f1 }

 k := random(100) + 1;

 write('Длина 1: ', k, ' ');

 for i := 1 to k do

   f1[i] := random(199) - 99; { число от -99 до 99 }

 p1 := l(f1);

 writeln(', вычислена длина ', p1);

 s := 'f1';

 { f2 }

 k := random(100) + 1;

 write('Длина 2: ', k);

 for i := 1 to k do  

   f2[i] := random(199) - 99;

 p2 := l(f2);

 writeln(', вычислена длина ', p2);

 if p2 > p1 then

 begin

   p1 := p2;

   s := 'f2';

 end;

 { f3 }

 k := random(100) + 1;

 write('Длина 3: ', k, ' ');

 for i := 1 to k do  

   f3[i] := random(199) - 99;

 p2 := l(f3);

 writeln(', вычислена длина ', p2);

 if p2 > p1 then

 begin

   p1 := p2;

   s := 'f3';

 end;

 { f4 }

 k := random(100) + 1;

 write('Длина 4: ', k, ' ');

 for i := 1 to k do  

   f4[i] := random(199) - 99;

 writeln(', вычислена длина ', p2);

 if p2 > p1 then

   s := 'f4';

 write('Самый длинный массив ', s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота