Ilia1098374
23.02.2020 15:19

Нужно написать программу для определения средней температуры месяца(9класс)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Strelkov18
07.02.2020 04:20
0. 1
1. 10
2. 1001
3. 10010110
4. 1001011010010110
5. 10010110100101101001011010010110

После четвёртого шага я заметил, что наша строка состоит из подстрок "1001" и "0110". Количество таких подстрок после третьего шага начинает увеличиваться в два раза с каждым шагом. Например, в третьем шаге подстрока"10010110" - одна, а в четвёртом - две. Исходя из этого можно вынести, что в пятом шаге их - четыре (кто сомневается - проверьте). Составим таблицу, благодаря которой мы узнаем, сколько подстрок "10010110" будет в строке после одиннадцатого шага:
3. 1
4. 2
5. 4
6. 8
7. 16
8. 32
9. 64
10. 128
11. 512

После одиннадцатого шага строка будет иметь 512 подстрок "10010110" - то есть, состоять из 512 * 8 = 4096 символов. Это всего лишь отступление.

В одной подстроке "10010110" - 4 единицы. Значит, в 512 таких подстроках их будет 512 * 4 = 2048 штук.

ответ: 2048.
0,0(0 оценок)
Ответ:
sanekakot
19.11.2021 17:40
1)
var A,B: array[1..200] of real;
N, i: integer;
begin
write('Введите количество элементов массивов A и B: ');
readln(N);
writeln('Введите значения элементов массива A');
for i:=1 to N do read(A[i]);
writeln();
for i:= 1 to N do
if (i mod 2 = 0) then B[i]:=i*A[i]
else B[i]:=-A[i];
writeln('Массив В:');
for i:=1 to N do write(B[i]:2:2,' ');
end.

2)
var A: array[1..200] of integer;
N, i: integer;
begin
write('Введите количество элементов массива A: ');
readln(N);
randomize;
for i:=1 to N do
    A[i] := random(86)-15;
writeln('Массив А: ');
for i:=1 to n do write(A[i], ' ');
end.
 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота