manetsevap010xz
05.04.2021 03:13

Напишите программу паскаль. вроде циклы дано натуральное число n. определить, является ли оно совершенным. совершенное число n равно сумме его делителей, не превосходящих само n.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
davas255
25.06.2020 15:53
Program gt;
var n,s,l,i:longint;
begin
read(n);
s:=0;
l:=round(sqrt(n));
for i:=1 to l do
begin
if(n mod i=0)then begin
s:=s+i;
s:=s+n div i;
end;
end;
if(l*l=n)then s:=s-l;
if(s<=n)then writeln('ДА ЭТО ПРАВДА')else writeln('НЕТ');
end.
2)
program gt;
var n:integer;
begin
read(n);
if(n=1)then writeln('ДА')else writeln('НЕТ');
end.
3)
program gt;
var n,s:integer;
begin
read(n);
s:=((1+n)*n)div 2;
writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота