elimasataeva
05.04.2021 03:13

Написать программу для паскаля. дана квадратная матрица порядка n(n=5). если в данной матрице a нет отрицательных элементов, то транспонировать её, иначе выдать сообщение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
555555Рок1111
25.06.2020 15:52
Uses crt;
const N=2;
var a:array [1..N,1..N] of real;
    i,j,k:integer;
begin
     k:=0; writeln('Введите матрицу:');
     for i:=1 to N do
         for j:=1 to N do
         begin
              read(a[i,j]);
              if a[i,j]<0 then inc(k);
         end;
     if k>0 then writeln('В матрице отрицательный элемент')
     else
         for i:=1 to N do
         begin
             for j:=1 to N do
             write(a[j,i]:3:0);
             writeln;
         end;
end.      
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота