ksusha2311021
01.06.2021 09:14

Как много смыслов в простом пожелании! Напишите программу, которая найдет все строки, в которых есть что-то доброе (достаточно проверить наличие подстроки добр), а потом выберет из них строку с наименьшей длиной. Формат ввода

Вводятся строки, пока не будет введена строка с фамилией Бэггинс.

Формат вывода

Вывести наименьшую длину строки, в которой есть что-то доброе. Если таких не оказалось, вывести 0.Торопиться некуда таким добрым утром, целый день впереди!

От них одно беспокойство и неприятности!

Еще,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kuanyshqz
29.01.2022 17:09
1.
var
x:integer;
y:real;
begin
write('Введите значение аргумента "X" : ');
readln(x);
y:=3*cos((5*x));
writeln('Значение функции "Y" = ',y);
readln;
end.

2.
var
x,b:integer;
begin
write('Введите количество молока, полученного за день, л : ');
readln(x);
write('Введите количество дней : ');
readln(b);
writeln('Количество молока, полученного за заданный промежуток времени = ',x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write('Введите двузначное число: ');
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write('Введите целое число: ');
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write('Введите числа : ');
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понялЕсли оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}
0,0(0 оценок)
Ответ:
maks737
29.01.2022 17:09
1.
var
x:integer;
y:real;
begin
write('Введите значение аргумента "X" : ');
readln(x);
y:=3*cos((5*x));
writeln('Значение функции "Y" = ',y);
readln;
end.

2.
var
x,b:integer;
begin
write('Введите количество молока, полученного за день, л : ');
readln(x);
write('Введите количество дней : ');
readln(b);
writeln('Количество молока, полученного за заданный промежуток времени = ',x*b);
readln;
end.  

3.
var
a,b,c:integer;
begin
write('Введите двузначное число: ');
readln(a);
b:=a div 10;
c:=a mod 10;
writeln(b,#10,c);
end.

4.
var
b:integer;
a:longint;
begin
write('Введите целое число: ');
readln(a);
  b:=a div 100 mod 100;
writeln(b);
readln;
end.

5. 
var
a,b:integer;
begin
write('Введите числа : ');
readln(a,b);
if a and b mod 2=0 then
 writeln(a+b);
if a and b mod 2<>0 then
 writeln(a*b);
readln;
end.
{Про последнее "Иначе", увеличьте все числа в пять раз и выведите результаты" не очень понялЕсли оба чётные - сумма, если оба - нечётные - то произведение. А если иначе, то число должно быть равно нулю. Смысл увеличивать его в пять раз?)}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота