karapetyanhovn1
09.05.2020 04:18

Написать программу в паскаль по двумернрму массиву. Задан двухмерный массив чисел. Элементы матрицы вводятся с клавиатуры. Найти среди четных элементов матрицы максимальный элемент. Вывести результат.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pro9377196
15.02.2022 22:56

                  Визуализация:                          Инфографика"

Цель:       Сделать данные              Сделать идею очевидной

         наглядными для читателя        для читателя, показать

                                                                           ему вывод

Задачи:      Связаны с данными:       Связаны с читателем:

                        1) показать                    1) привлечь внимание

                       2) сравнить понят                                                    

                       3) организовать           3) побудить к чему-то

                       4) связать

Объяснение:

Наверно так

Желание автора:

Став лайк)

0,0(0 оценок)
Ответ:
Elnur19982
15.02.2022 22:56

Відповідь:

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

void SetArray(int *A,int N){

for(int i = 0; i < N; i++){

 A[i] = rand() % 10 + 1;

}

}

void PrintArray(int *A,int N){

for(int i = 0;i < N; i++){

 cout << A[i] << " ";

}

}

void expression(int *A,int N,int k,int l){

for(int k; k <= l; k++, l--){

 swap(A[k], A[l]);

}

}

int main(){

       srand(time(NULL));

setlocale(LC_ALL , "Rus");

int N,k,l;

cout << "Введите размер массива: ";

cin >> N;

int *A = new int[N];

 SetArray(A,N);

 PrintArray(A,N);

 

 cout << "\nВведите k: ";

 cin >> k;

 cout << "Введите l: ";

 cin >> l;

 

 expression(A,N,k,l);

 PrintArray(A,N);

delete[] A;            

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота