maksik008
20.10.2021 04:03

Необходимо написать программу для вычисления выражения на языке СИ, используя следующие данные


Необходимо написать программу для вычисления выражения на языке СИ, используя следующие данные

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
маринка150
26.12.2020 09:01

мальчик высаживает второго мальчика на втором берегу, сам отправляется на первый. там, он выходит из лодки и сажает вместо себя солдата. солдат перемещается на второй берег и выходит. "за руль" садится мальчик и плывет к 1ому берегу, берет 2ого пацана и они оба "едут" на второй берег. там один мальчик выходит. 2ой отправляется на первый берег меняется местами со вторым солдатом и солдат плывет на второй берег. там второй пацан садится в лодку и плывет на первый берег за другом. Результат: бойцы переправились, а мальчики снова катаются.

 

Удачи..

0,0(0 оценок)
Ответ:
ALEXGEEK
20.04.2021 13:29

var a,b,c:integer; стороны для треугольника
s,p:real;
begin
write('Введите сторону а = ');readln(a);
write('Введите сторону b = ');readln(b);
write('Введите сторону c = ');readln(c);
if ((a < b + c) or (b < a + c) or (c < a + b)) then begin проверка на существовании треугольника, а то как площадь получить если треугольника нет=)
p:=(a+b+c)/2; формула полупериметра 
s:=Sqrt(p*(p-a)*(p-b)*(p-c)); формула Герона для нахождении площади треугольника
writeln('Площадь треугольника равна s = ',s:0:4);
end else writeln('Треугольник не существует!');
end.

 

П.С. что не понятно постараюсь объяснить, но я думаю вы прекрасно во всем разберетесь;)

 

Во вложении блок схема

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота