Kate00013
02.08.2022 19:38

C++ нужно написать программу которая бы из целого числа делала сумму чисел и произведение (в двух разных строчках)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lis316721
04.12.2021 18:50

#include <iostream>

using namespace std;

int main(){

   string n;

   int sum;

   while (true){

       sum=0;

       cout<<"\nEnter integer : ";

       cin>>n;

       for (int i=0; i<n.size(); i++)

           sum+=n[i]-'0';

       cout<<"Sum of digits : "<<sum<<endl;

       system("pause");

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота