3035111236
09.07.2021 11:06

Составить программу решения задачи с использованием условного оператора (первое задание). 1. Ввести три действительных числа х, у и z. Вычислить значения q и w по формулам
q=mах(ху,х+уz,у+хz); w = min(х+2у+z, 2х+у+ z)+1. Напечатать их

Составить программу решения задачи с использованием оператора выбора (второе задание).
2. Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Evloevakhava
08.11.2020 20:33
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3
0,0(0 оценок)
Ответ:
alino4ka2012
08.11.2020 20:33
function Gcd(a,b: longint): longint;
{ Нахождение НОД }
var
  i: longint;
begin
  while b <> 0 do
  begin
    a := a mod b;
    i := b; b := a; a := i
  end;
  gcd := a
end;

procedure ShortFraction(var m,n:longint);
var
  k:longint;
begin
  k:=Gcd(m,n);
  m:=m div k; n:=n div k
end;

var
  a,b:longint;
begin
  Write('Введите числитель и знаменатель дроби: '); Readln(a,b);
  ShortFraction(a,b);
  Writeln('Дробь после сокращения равна ',a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби: 25 15
Дробь после сокращения равна 5/3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота