TheLoneRider
03.04.2020 12:37

Определите результат работы программы. Запишите матема- тическую формулу для вычисления значения from math import a = 12 . b = 5 с = 13 р = (a + b + c) / 2 S = p с *= p - а S = p s *= P С S = sqrt(s) print (s) 14 Для зале тчислите и по формуле

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
агтл
29.11.2020 08:40
Var
   Text,S:string;
   n,k:boolean;
   i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
    Begin
    if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
    else // как только встречаем другой символ, проверяем,
       if Length(S) > 0 then // есть ли в S хоть одна буква,
          Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
          if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
          S:=''; // далее обнуляем S
          End;
    End;
End.

Пример работы программы:

Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
0,0(0 оценок)
Ответ:
гуля429
29.11.2020 08:40

1)это процесс передачи информации о состоянии объекта объекту.

2) алгоритм в системе без обратной связи имеет линейную (последовательную) структуру.

3)при наличии обратной связи алгоритм может быть более гибким, допускающим проверку условий, ветвления и циклы

4)системы, в которых роль объекта поручается компьютеру, называются автоматическими системами с программным .

5) объект - учитель, а ученики являются объектом . прямой канал передачи информации - передача знаний учителем, а обратная связь - ответы учеников, результаты контрольных работ, сочинения и т. п. учителю обратная связь дает информацию о достижении поставленных им целей - когда ученики выполнили .  

6)цикл: учитель выставляет оценки в журнал; ветвление: если иванов , то учитель его выгоняет, если нет(иначе) оставляет в классе.

7)модель с обратной связью

8)информативная доска с голосовой подачей информации. используется видео микрофон с распознованием ученика.(можно сделать для каждого ученика отдельную клавиатуру с которой он будет вводить вопрос,тем самым повышая мобильность системы)

из плюсов: мобильность,скорость работы простое .

из минусов: индивидуальность,стандартное мышление

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота