prostosadkotik
25.03.2020 14:19

Возвести в квадрат все элементы массива A. Написать программу Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ladakorobova
28.05.2023 07:53

1.Объективность=Эти брюки стоят три тысячи рублей

2.Необъективность=Эти брюки дорого стоят

3.Достоверность= все ныне живущие люди умрут

4.Недостоверность=люди бессмертны

5.Полнота=Ира, моя родная сестра, приехала погостить на пару дней

6.Неполнота=девушка

7.Актуальность=на вашем счёте 2 рубля

8.Неактуальность=в 1894 на счёте вашего прапрадедушки было семь шекелей

9.Ценная информация=хорошо написанная статья о том как вылечить больную печень. эта информация ценна для пьяницы

10.Не ценная=та же статья но для здорового шахтёра в уральских горах ценна не будет

11.Понятная информация=в долларе 56,89 рубля

12.Непонятная информация=ドル56.89ルーブル

Объяснение:

0,0(0 оценок)
Ответ:
nastyanas4
21.04.2023 17:11
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота