eruder
08.10.2020 19:22

Напишите 2 программы на паскале.
Нужно написать программу математического выражения


Напишите 2 программы на паскале. Нужно написать программу математического выражения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
cobaincurt
07.10.2021 22:16

program mas;

var

 number_month, i, amount, quantity, min: integer;

 A: array [1..15] of integer;

begin

 for i := 1 to 15 do  

 begin

   read(A[i]);

 end;

 min := A[1];

 for i := 1 to 15 do  

 begin

   if (A[i] mod 3 = 0) then

     amount := amount + A[i];

   if (A[i] > 20) and (A[i] < 80) then

     inc(quantity);

   if (A[i] < min) then

     min := A[i];

 end;

 writeln('Минимум: ', min);

 writeln('Сумма элементов, кратных 3: ', amount);

 writeln('Количество чисел > 20 и < 80: ', quantity);

end.

Объяснение:

program mas;  // Название программы

var  

 i, amount, quantity, min: integer; // Целочисленные переменные:

i - счётчик для foramount - сумма элементов, кратных 3quantity - количество элементов > 20 и < 80min - минимальный элемент массива

 A: array [1..15] of integer;  // Массив целочисленного типа А с индексами от 1 до 15

begin  // Начало программы

 amount := 0;  // Переменная, отвечающая за сумму элементов, кратных 3, равна 0

 quantity := 0; // Переменная, отвечающая за количество элементов >20 и <80, равна 0

 for i := 1 to 15 do  // Цикл для ввода пятнадцати чисел в массив

 begin  // Начало цикла

   read(A[i]);  // Ввод значений с клавиатуры

 end;  // Конец цикла

 min := A[1];  // Значение переменной, отвечающей за минимальный элемент массива, равен первому элементу массива

 for i := 1 to 15 do  // Цикл для прогона всех чисел массива

 begin  // Начало цикла

   if (A[i] mod 3 = 0) then  // Если значение элемента массива с индексом i делится на 3 без остатка, тогда

     amount := amount + A[i];  // Сумма = сумма + значение элемента массива с индексом i

   if (A[i] > 20) and (A[i] < 80) then  // Если значение элемента массива с индексом i > 20 И < 80, тогда

     inc(quantity);  // Увеличиваем значение переменной quantity на 1

   if (A[i] < min) then  // Если значение элемента массива с индексом i < значения переменной min, тогда

     min := A[i];  // Значение переменной min = значению элемента массива с индексом i

 end;  // Конец цикла

 writeln('Минимум: ', min);  // Вывод минимума

 writeln('Сумма элементов, кратных 3: ', amount);  // Вывод суммы элементов, попадающих под условие

 writeln('Количество чисел > 20 и < 80: ', quantity);  // Вывод количества чисел, попадающих под условие

end. // Конец программы

0,0(0 оценок)
Ответ:
Irrishka2005
22.02.2021 14:48

program season;

var

 number_month: integer;

begin

 write('Введите номер месяца: ');

 read(number_month);

 case number_month of

   1, 2, 12: writeln('Зима.');

   3..5: writeln('Весна.');

   6..8: writeln('Лето.');

   9..11: writeln('Осень.');

 else writeln('Неверный номер месяца.');

 end

end.

Объяснение:

program season;  // Название программы

var

 number_month: integer;  // Целочисленная переменная, отвечающая за вводимый номер месяца с клавиатуры

begin  // Начало программы

 write('Введите номер месяца: ');  // Вывод сообщения

 read(number_month);  // Ввод номера месяца с клавиатуры

 case number_month of  // Принимает значение переменной number_month

   1, 2, 12: writeln('Зима.');  // Если значение переменной number_month = 1, 2, 12, то выводим "Зима"

   3..5: writeln('Весна.');  // Если значение переменной number_month = 3, 4, 5, то выводим "Весна"

   6..8: writeln('Лето.');  // Если значение переменной number_month = 6, 7, 8, то выводим "Лето"

   9..11: writeln('Осень.');  // Если значение переменной number_month = 9, 10, 11, то выводим "Осень"

 else writeln('Неверный номер месяца.');  // Иначе выводим сообщение об ошибке

 end  // Конец функции

end. // Конец программы

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота