qwidonsky
10.10.2022 01:32

Программа получает на вход две строки, содержащие даты, записанные в формате dd.mm., где dd – день месяца от 01 до 31, mm – номер месяца от 01 до 12, – номер года от 0001 до 2999. Программа должна вычислить разность между этими датами (количество дней между ними) и вывести ответ в виде натурального числа. Обе даты корректные, вторая позже первой. Учтите, что года, чьи номера делятся на 4 и не делятся на 100, а также все года, чьи номера делятся на 400 являются високосными.

Пример
Вход Выход
01.01.0001 1
02.01.0001

Вход Выход
29.02.2004 366
01.03.2005

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лесечка14
21.02.2023 21:41

#include <iostream>

using namespace std;

int main()

{

   const int time = 86400;

   int a;

   cout << "Enter the time in seconds elapsed since the beginning of the day" << endl;

   cin >> a;

   int hh = a % time / 3600;

   int mm = a / 60 % 60;

   int ss = a % 60;

   int endhh, endmm, endss;

   int tmp = hh * 3600 + mm * 60 + ss;

   tmp = time - tmp;

   endhh = tmp / 3600;

   endmm = tmp / 60 - endhh * 60;

   endss = tmp - endmm * 60 - endhh * 3600;

   cout << "Now is: " << hh << " hh: " << mm << " mm: " << ss << " ss" << endl;

   cout << "before the midnight: " << endhh << " hh: " << endmm << " mm: " << endss << " ss" << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
алина3882
21.02.2023 21:41

#include <iostream>

using namespace std;

int main()

{

   const int time = 86400;

   int a;

   cout << "Enter the time in seconds elapsed since the beginning of the day" << endl;

   cin >> a;

   int hh = a % time / 3600;

   int mm = a / 60 % 60;

   int ss = a % 60;

   int endhh, endmm, endss;

   int tmp = hh * 3600 + mm * 60 + ss;

   tmp = time - tmp;

   endhh = tmp / 3600;

   endmm = tmp / 60 - endhh * 60;

   endss = tmp - endmm * 60 - endhh * 3600;

   cout << "Now is: " << hh << " hh: " << mm << " mm: " << ss << " ss" << endl;

   cout << "before the midnight: " << endhh << " hh: " << endmm << " mm: " << endss << " ss" << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота