sofjiasofa123456
03.01.2023 03:24

данный код перевести из Паскаля в Питон for i:=1 to n do
begin
S:=S+sqr(A/i);
V:=V+h*sqr(A/i);
M:=M+p*h*sqr(A/i);
end;
writeln('Площадь поверхности S=',S:5:2);
writeln('Объем V=',V:5:2);
writeln('Масса M=',M:5:2);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
яшка37
29.05.2021 02:03

Напишите программу (python), которая соберет все подарки Иа от всех друзей.

Формат ввода

Целое число — количество строк, затем сами строки, в которых сначала вводится подарок, а потом через дефис, окруженный пробелами, имя друга.

Формат вывода

Вывести для каждого друга (друзья выводятся в обратном алфавитном порядке) список его подарков Иа, но уже в алфавитном порядке. Формат вывода:

Друг: подарок, подарок, подарок

Ввод

5

Букет из чертополоха - Кролик

Бант для хвоста - Кристофер Робин

Гвоздик для хвоста - Кристофер Робин

Спаржевый пудинг - Кролик

Зеленая тряпочка - Пятачок

Вывод

Пятачок: Зеленая тряпочка

Кролик: Букет из чертополоха, Спаржевый пудинг

Кристофер Робин: Бант для хвоста, Гвоздик для хвоста

0,0(0 оценок)
Ответ:
GoldenLynx1999
28.05.2022 21:19
1. Выразим выражения по правилам языка Pascal:
a) 5 * 2 - 4
Решение:
Умножение имеет более высокий приоритет, чем вычитание. Поэтому, сначала выполним вычисление умножения: 5 * 2 = 10.
Затем, выполним вычитание: 10 - 4 = 6.
Ответ: 6.

б) 7 * х + 2
Решение:
Умножение имеет более высокий приоритет, чем сложение. Поэтому, сначала выполним вычисление умножения: 7 * х = 7х.
Затем, выполним сложение: 7х + 2.
Ответ: 7х + 2.

в) 8 * х - 3 * (х + у)
Решение:
Выполним умножение: 8 * х = 8х и 3 * (х + у) = 3х + 3у.
Затем, выполним вычитание: 8х - (3х + 3у).
Для выполнения операции в скобках, умножение 3 на каждый из элементов внутри скобок:
8х - 3х - 3у = 5х - 3у.
Ответ: 5х - 3у.

г) v^2 * х * у^2 * х * у
Решение:
По правилам алгебры, умножение можно проводить в любом порядке.
Выполним умножение: v^2 * х = v^2х, у^2 * х = у^2х, v^2х * у^2х = (vх * у)^2х.
Ответ: (vх * у)^2х.

2. Переведем запись с языка Pascal в нормальную форму:
f = (3 * x + 4 * y)/(2 * sqr(к) - 4 * t / y)
Решение:
Нормализация выражения подразумевает разделение на более простые составляющие.
Заменим sqr(к) на к^2, чтобы выразить возведение в квадрат в общепринятой форме:
f = (3 * x + 4 * y)/(2 * к^2 - 4 * t / y)
Затем, выполним умножение и деление в числителе и знаменателе:
f = (3 * x + 4 * y)/(2к^2 - (4 * t) / y)
Ответ: f = (3 * x + 4 * y)/(2к^2 - 4t/y).

Таким образом, мы записали выражения по правилам языка Pascal и перевели запись с языка Pascal в нормальную форму.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота