Barvina779
24.11.2021 16:18

НА ЛЮБОМ ЯЗЫКЕ (pascal abc, python? gnu c++, gnu c11, C# MS .Net 5.0) Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt

У Васи есть n пустых коробок. Для каждого i (1 ≤ i ≤ n) i-я коробка — это куб со стороной длины ai.

Вася может положить коробку i в другую коробку j, если соблюдаются следующие условия:

i-я коробка не лежит в другой коробке;

j-я коробка не содержит других коробок;

коробка i меньше коробки j (ai < aj).

Вася может сколько угодно раз класть коробки друг в друга. Он хочет минимизировать количество видимых коробок. Коробка называется видимой, если она не лежит в какой-либо коробке.

определить минимальное возможное количество видимых коробок!

Формат ввода
В первой строке записано одно целое число n (1 ≤ n ≤ 5000) — количество коробок у Васи.

Формат вывода
Во второй строке записаны n целых чисел a1, a2, ..., an (1 ≤ ai ≤ 109), где ai — длина стороны i-й коробки.

Пример 1
Ввод Вывод
3
1 2 3
1
Пример 2
Ввод Вывод
4
4 2 4 3
2
Пример 3
Ввод Вывод
8
1 2 1 2 3 2 3 3
3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Roland227
28.10.2021 18:35

но не знаю что такое коэффициент на двоих в пещерах в основном в том тел.всё что в пещерах в телефон на котором он был включён в пещерах в основном на улице но в основном в районе улицы горького в пещерах в я не могу двигаться дальше но это не я не могу двигаться дальше но это не я не могу двигаться дальше но это не я не могу двигаться дальше но это не я не могу двигаться дальше но это не я не могу двигаться дальше

я не могу двигаться дальше но это не я не могу двигаться дальше но это не я не могу двигаться дальше

0,0(0 оценок)
Ответ:
yakymov
17.01.2022 04:30
Const n=4; m=5;
var a:array [1..n,1..m] of integer;
 i,j,min,imin,jmin:integer;
begin
Randomize;
Writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do begin
 a[i,j]:=random(21)-10;
 write(a[i,j]:6);
 end;
writeln;
end;
min:=a[1,1]; imin:=1;jmin:=1;
for i:=1 to n do
 for j:=1 to m do
  if a[i,j]<min then
   begin min:=a[i,j]; imin:=i; jmin:=j; end;
writeln('min=a[',imin,',',jmin,']=',min);
end.

Пример:
Исходный массив:
     5     8     2    -5    -4
     1   -10     9     1    -4
     8     2    -6    -4    -4
     8     7     3     2     2
min=a[2,2]=-10
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота