runazh
06.07.2022 14:21

разобраться с задачей в ЛамПанель Составьте программу, удаляющую все лишние пробелы из данной строки,
т.е. оставьте между словами не более одного пробела.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lancerevol12p0cjct
04.01.2020 03:41

const n=5;

var

 a:array [1..n,1..n] of integer;

 i,j,k:integer;

begin

 k:=0;

 for i:=1 to n do

   begin

     for j:=1 to n do

       begin

         a[i,j]:=random(151)-50;

         write(a[i,j]:4);

         if (a[i,j] mod 5 =0) then  

             inc(k);

       end;

     writeln;

   end;

   writeln;

     if k<>0 then

       begin

         for i:=1 to n do

           begin

             for j:=1 to n do

               begin

                 if a[i,j]=k then a[i,j]:=0;

                 write(a[i,j]:4);

               end;

             writeln;

           end;

         writeln('K= ',k);

       end

         else  

           begin

             for i:=1 to n do

               begin

                 for j:=1 to n do

                   begin

                     a[i,j]:=0;

                     write(a[i,j]:4);

                   end;

                 writeln;

               end;

              writeln('K= 0');  

           end;

end.

0,0(0 оценок)
Ответ:
Dimkakrut
13.11.2020 07:50

Объяснение:

1. Нарушение требований настоящего Федерального закона влечет за собой дисциплинарную, гражданско-правовую, административную или уголовную ответственность в соответствии с законодательством Российской Федерации.

1.1. Лица, виновные в нарушении требований статьи 14.1 настоящего Федерального закона в части обработки, включая сбор и хранение, биометрических персональных данных, несут административную, гражданскую и уголовную ответственность в соответствии с законодательством Российской Федерации.

(часть 1.1 введена Федеральным законом от 31.12.2017 N 482-ФЗ)

2. Лица, права и законные интересы которых были нарушены в связи с разглашением информации ограниченного доступа или иным неправомерным использованием такой информации, вправе обратиться в установленном порядке за судебной защитой своих прав, в том числе с исками о возмещении убытков, компенсации морального вреда, защите чести, достоинства и деловой репутации. Требование о возмещении убытков не может быть удовлетворено в случае предъявления его лицом, не принимавшим мер по соблюдению конфиденциальности информации или нарушившим установленные законодательством Российской Федерации требования о защите информации, если принятие этих мер и соблюдение таких требований являлись обязанностями данного лица.

3. В случае, если распространение определенной информации ограничивается или запрещается федеральными законами, гражданско-правовую ответственность за распространение такой информации не несет лицо, оказывающее услуги:

1) либо по передаче информации, предоставленной другим лицом, при условии ее передачи без изменений и исправлений;

2) либо по хранению информации и обеспечению доступа к ней при условии, что это лицо не могло знать о незаконности распространения информации.

4. Провайдер хостинга, оператор связи и владелец сайта в сети "Интернет" не несут ответственность перед правообладателем и перед пользователем за ограничение доступа к информации и (или) ограничение ее распространения в соответствии с требованиями настоящего Федерального закона.

(часть 4 введена Федеральным законом от 02.07.2013 N 187-ФЗ; в ред. Федерального закона от 24.11.2014 N 364-ФЗ)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота