kodraemail
21.11.2020 05:36

Составить программу нахождения всех 4_х значных чисел, сумма составляющих которых равно заданному числу k=5.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
elenatsushko
30.11.2021 19:10

program tz;

var

n,k,i,nach,pred:integer;

Function SumCifr(l:integer):integer;

var

s:string;

sum,i,j,err:integer;

begin

str(l, s);

sum:=0;

for i:= length(s) downto 1 do

begin

val(s[i],j,err);

sum:=sum+j;

end;

SumCifr:=sum;

end;

Procedure Cifri(nach,pred,k:integer);

var

i:integer;

begin

for i:=nach to pred do

if SumCifr(i)=k then

Write(i, ' ');

end;

begin

writeln('k = ');

readln(k);

writeln('n = ');

readln(n);

if n<5 then

begin

nach:=1;

for i:=1 to n-1 do

nach:=nach*10;

pred:=nach*10-1;

Cifri(nach,pred,k)

end

else

begin

nach:=10000;

pred:=32767;

Cifri(nach,pred,k);

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота