begemot14
14.10.2022 08:53

Напишите программу( в паскале авс), которая находит нок (наименьшее общее кратное) двух чисел, введённых с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nyanchann
25.06.2020 12:55
Для решения этой задачи воспользуемся формулой:
а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота