nikzarubenko
13.05.2021 12:23

Написать программу, которая вычисляет частное от деления двух чисел. Программа должна проверять правильность введенных пользователем данных и, если они неверные (делитель равен нулю), выдавать сообщение об ошибке. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Новый текстов...

Вычисление частного.

Введите в одной строке делимое и делитель, затем нажмите <Enter>

->12 O Вы ошиблись. Делитель не должен быть равен нулю. п
Сделать на JAVA SCRIPT

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Братюня11
11.02.2021 14:18
Обьясняется различие в размерах файлов тем, что разные кодировки используют разное кол-во памяти, к примеру обычный *.txt файл хранит просто упорядоченный набор символов, а *.rtf уже хранит такие характеристики как размер шрифта цвет выравнивание и много других параметров. Разные расширения текстовых данных сделаны для хранения максимального кол-ва данных в наименьшем возможном ко-во памяти (txt), и наоборот хранения текста в исходном виде с исходными характеристиками (rtf). Ну а размеры файлов можешь и сам посмотреть сделав эту лабу. Эхх... бывают же ленивые люди(((
0,0(0 оценок)
Ответ:
av45
11.02.2021 14:18
Ну если сортировка на паскале, то держи
uses crt;
type mas=array[1..1000] of integer;
var a:mas;
    n,i:integer;
procedure gnomesort(var arr:mas; size : Integer);
var i, j, t  : Integer;
begin
i := 2;
j := 3;
while i <= size do
 begin
  if arr[i-1] <= arr[i] then
   begin
    i := j;
    j := j + 1
   end
  else
   begin
    t := arr[i-1];
    arr[i-1] := arr[i];
    arr[i] := t;
    i := i - 1;
  if i = 1 then
   begin
    i := j;
    j := j + 1
   end
  end
 end;
end; begin
 write('Размер массива n=');
 read(n);
 writeln('Исходный массив:');
 for i:=1 to n do
 read(a[i]);
 writeln;
 gnomesort(a,n);
 writeln('Результат сортировки:');
 for i:=1 to n do
 write(a[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота